pi-topUtils 1.05

Keyboard/HID driver and battery indicator for pi-top laptops
JonAbbott
Posts: 2109
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: pi-top utilities

Post by JonAbbott » Mon Oct 08, 2018 6:24 pm

Vanfanel wrote:
Mon Oct 08, 2018 4:03 pm
Pac-Mania title screen with the scrolling film-like graphics, Fireball II scrolling text...
Other games DON'T show this problem, like HeroQuest scrolling text, that's perfectly smooth with no hiccups.
What mode do you have configured in CONFIG/TXT? Are you using my custom 1360x768 50Hz mode?
Vanfanel wrote:
Mon Oct 08, 2018 4:03 pm
-There's still the problem that I get a 'B' character sometimes if I tap on the trackpad. Can you see that? You must have an editor open to see it.
My trackpad doesn't do that. Perhaps your firmware treats a tap as a mouse click, but is passing the wrong USB code? Go to BASIC, enter the following and let me know what number it returns when you tap the trackpad:

Code: Select all

PRINT INKEY(8000)
You might need to figure out how to reliably reproduce the issue. It will probably be a single tap, double tap or two finger tap.

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: pi-top utilities

Post by Vanfanel » Mon Oct 08, 2018 7:53 pm

@Jon:

-Regarding the BASIC command, I sometimes get a 9, but it's hard to get...
I am also having stuck-keys, like in thiiiiiiiiiiiiiiii... until I press the letter again.
-Regarding the video issue: yes, I am using your custom 50Hz mode. If I wouldn't be using it, I wouldn't be having perfect scroll in most games.

JonAbbott
Posts: 2109
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: pi-top utilities

Post by JonAbbott » Mon Oct 08, 2018 10:04 pm

Vanfanel wrote:
Mon Oct 08, 2018 7:53 pm
-Regarding the BASIC command, I sometimes get a 9, but it's hard to get...
A 9 is a Left mouse click, how that would result in a "B" on the keyboard I have no idea!
Vanfanel wrote:
Mon Oct 08, 2018 7:53 pm
I am also having stuck-keys, like in thiiiiiiiiiiiiiiii... until I press the letter again.
It's either power issues, or USB data is being missed/dropped. Do you have anything plugged into USB other than the pi-top hub?
Vanfanel wrote:
Mon Oct 08, 2018 7:53 pm
-Regarding the video issue: yes, I am using your custom 50Hz mode.
What's the issue, you didn't actually say?

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: pi-top utilities

Post by Vanfanel » Tue Oct 09, 2018 9:53 am

@Jon: Nothing plugged on the USB, other than the Pi-top.
Also, the video issue is that there's a "jump" every 8 seconds or so on finescrolling sequences in some games. But only in some games: Fireball II tittle screen (scrolling text), Pac Mania (tittle screen scrolling film-like squares), etc... It only seems to happen with your custom 50Hz 1360x760 video mode: it does't happen with hdmi_mode=31.
Maybe the custom video mode timings could be adjusted somehow?

JonAbbott
Posts: 2109
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: pi-top utilities

Post by JonAbbott » Tue Oct 09, 2018 11:06 am

Vanfanel wrote:
Tue Oct 09, 2018 9:53 am
there's a "jump" every 8 seconds or so on fine scrolling sequences in some games. But only in some games: Fireball II title screen (scrolling text), Pac Mania (title screen scrolling film-like squares), etc... It only seems to happen with your custom 50Hz 1360x760 video mode: it does't happen with hdmi_mode=31.
Microstutter then. As its not occurring in 1080p @ 50hz, the timing for the custom mode might be drifting out slightly. I don't think there's anything I can do to magically fix it, but I'll have a look.

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: pi-top utilities

Post by Vanfanel » Tue Oct 09, 2018 11:17 am

Yeah, microstutter is the word... sorry, I had forgotten, bacause you got ADFFS to work PERFECT in the standard 50Hz modes years ago, so I had not seen them since then. English is not my native language (I think you guessed that by now anyway :D)

There are games that don't show microstutter, like HeroQuest intro scrolling text. So maybe the timing drift affects some games but not others... strange thing, but at least that could be used to come up with a solution.

JonAbbott
Posts: 2109
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: pi-top utilities

Post by JonAbbott » Wed Oct 10, 2018 10:19 am

I've had a look at both the Pac-Mania and Fireball II title screens in debug mode, neither are frame swapping, so its not actually microstutter but tearing where the blitter is grabbing the frame mid-update. Short of modifying the game itself, I don't think there's anything I can do to fix the issue.

Its certainly unrelated to pi-top utilities or the 50hz hdmi_mode, so probably warrants a dedicated thread in the ADFFS development forum if a resolution is required.

JonAbbott
Posts: 2109
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: pi-top utilities

Post by JonAbbott » Wed Oct 10, 2018 11:48 am

Timo, I've rolled in your changes for pi-top2 hub support. Could you please try the attached (now removed) and confirm it detects the hub and works correctly.

It might also be worth seeing if the HID driver works, by changing the pitopUtils$DeviceID entry in !Run to match your keyboard. Let me know what the device ID is so I can add detection support for it.

If it doesn't work could you provide a USBDecriptors dump of it so I can see the endpoint descriptor.



EDIT: There appears to be an issue with this version as I've noticed the keyboard sometimes doesn't work.

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: pi-top utilities

Post by Vanfanel » Wed Oct 10, 2018 2:20 pm

JonAbbott wrote:
Wed Oct 10, 2018 10:19 am
I've had a look at both the Pac-Mania and Fireball II title screens in debug mode, neither are frame swapping, so its not actually microstutter but tearing where the blitter is grabbing the frame mid-update. Short of modifying the game itself, I don't think there's anything I can do to fix the issue.

Its certainly unrelated to pi-top utilities or the 50hz hdmi_mode, so probably warrants a dedicated thread in the ADFFS development forum if a resolution is required.
How comes the deffect happens ONLY when the Pi is connected to the PiTop?? :roll:

TimoHartong
Posts: 8
Joined: Wed Oct 10, 2018 8:44 pm

Re: pi-top utilities

Post by TimoHartong » Wed Oct 10, 2018 9:04 pm

Initial tests look good. However It seems that the keyboard functtion keys are not working as expected. I will send the text file in a moment. Code review looks good as well

Post Reply