ADFFS 2.66 beta

Discuss ADFFS development and download test releases
Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.66 beta

Post by Vanfanel » Tue Jun 05, 2018 8:12 pm

@Jon:
-The Dungeon works again, but the audio distortion is back! :(
-Flashback works again with no problem
-Elite works again with no problem, but crashes on quit (strange colors and crash)

JonAbbott
Posts: 2107
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.66 beta

Post by JonAbbott » Tue Jun 05, 2018 10:43 pm

Vanfanel wrote:
Tue Jun 05, 2018 8:12 pm
-The Dungeon works again, but the audio distortion is back! :(
That will be due to playing with the blitter priority while testing Diggers.
Vanfanel wrote:
Tue Jun 05, 2018 8:12 pm
-Elite works again with no problem, but crashes on quit (strange colors and crash)
Are you quitting via the menu quit option? You won't be able to use CTRL-SHIFT-F12 to terminate Wimp apps - it will fail horribly.

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.66 beta

Post by Vanfanel » Fri Jun 08, 2018 10:27 am

@Jon: I was quitting directly with CTRL-SHIFT-F12, so forget about the problem then :)

JonAbbott
Posts: 2107
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.66 beta

Post by JonAbbott » Sat Jun 09, 2018 12:11 am

There's a new build and obey.zip on the dev site.
Vanfanel wrote:
Mon Jun 04, 2018 1:29 pm
-Diggers: Goes into a black screen on launch.
This is a timing issue within the game. Some of the game code sits under the SCCB device handler, but there are sections of normal code that rely on the SCCB handler modifying counters, otherwise they get stuck in a race condition. I think I've botched it by forcing a frame blit immediately after a mode change, see if it now works.

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.66 beta

Post by Vanfanel » Sat Jun 09, 2018 11:53 am

@Jon: With today's build:
-Diggers works again with no problems. Great! :)
-The Dungeon does not seem to have any music distortion anymore!
-SR2000 does not show any music distortion either! So whatever you did regarding audio, keep it this way, please :D

I have noticed that Elite does not enter demo mode anymore (rotating ships), but goes straight into the menu.

JonAbbott
Posts: 2107
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.66 beta

Post by JonAbbott » Sun Jun 10, 2018 11:35 am

It seems I have some regressions to fix:
  • 2.63j broke Raw Power
  • 2.65g broke some games that use Service_ModeExtensions (K.V., Manchester United, Manchester United Europe)
  • 2.66b the priority change to the blitter broke Manchester United

JonAbbott
Posts: 2107
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.66 beta

Post by JonAbbott » Mon Jun 11, 2018 10:38 am

-E-Type II: Works fine, but display is letterboxed in a very bad way.
I've switched it to run as RISC OS 3.11, which should fix this.
JonAbbott wrote:
Sun Jun 10, 2018 11:35 am
  • 2.63j broke Raw Power
This is now fixed, 2.67b Modules and obey.zip on the dev site. I've changed the way Wimp tasks are handled hence the version bump, see if there's any change to all the failures you were seeing.

There's still a lot of changes to go in, its not currently PMP aware so you might see random machine hangs and there's possibly an issue with some BASIC code, Merp for example locks the machine solid. Always reboot after running a Wimp game, as some handlers aren't being removed correctly and are causing lockups and crashes.

Another regression I've spotted:
  • random screen corruption in Manchester United Europe

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.66 beta

Post by Vanfanel » Tue Jun 12, 2018 12:51 am

@jon: It seems that no polygons are now drawn in Elite (1.14). You can easily see that not only the demonstration screen is missing, but also the launch sequence lacks polygons.

JonAbbott
Posts: 2107
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.66 beta

Post by JonAbbott » Tue Jun 12, 2018 12:13 pm

Vanfanel wrote:
Tue Jun 12, 2018 12:51 am
It seems that no polygons are now drawn in Elite (1.14). You can easily see that not only the demonstration screen is missing, but also the launch sequence lacks polygons.
If its switched to RISC OS 3.11 emulation it works. It started in 2.65j when I changed ADFFS to only remap and return legacy screen addresses if its explicitly emulating RISC OS 3.11. I'll double check I've modified all the relevant code as its probably plotting the polygons to the wrong address.

Vanfanel
Posts: 476
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.66 beta

Post by Vanfanel » Thu Jun 14, 2018 11:03 am

@Jon: Who can I change it to RISC OS 3.11 emulation? I suppose it's by changing something on the boot script?

Post Reply