Interdictor on RiscOS 3

Discuss the project, or ask a general question
Post Reply
Posts: 1
Joined: Mon Aug 24, 2020 4:29 pm

Interdictor on RiscOS 3

Post by Amiarchie »

I've got an A3000 with RiscOS3, Arm3 and 4MB, but no HD.
Tried to play Interdictor, but even though it loads, it crashes at some point during gameplay (usually when giving input like pressing a button, but that could be coincidental).
Replicated my system on Arculator and it seems to run fine under OS2 (but not OS3)
I don't know much about RiscOS, but I tried downgrading some modules on the emu such as the CLib and FPEmulator, for which I loaded the version included with the game as well as 4.32, but it didn't help.
Also tried ADFFS' boot script on the emulator, but the problem persisted.
Is there a way to run it on my A3000?

Posts: 2423
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: Interdictor on RiscOS 3

Post by JonAbbott »

I'll have to check, but I recall seeing something similar when testing and possibly implementing a bug fix in the boot script. I may also be setting OS emulation to 2.0, in which case it's issuing an OS call that changed behaviour in RO 3.x

Post Reply