Search found 2155 matches

by JonAbbott
Sat Jan 18, 2020 9:22 am
Forum: Games
Topic: Lemmings (1991) (Krisalis Software)
Replies: 20
Views: 8670

Re: Lemmings (1991) (Krisalis Software)

sniffer wrote:
Wed Jan 15, 2020 8:26 pm
Anybody any idea what I haven't done this time around?
You need to remove AnyMode and set the resolution in config.txt

If you follow the requirements section in the ADFFS download page, it should work without issue.
by JonAbbott
Sat Jan 18, 2020 9:15 am
Forum: Games
Topic: Exodus [32bit version] (2018) (JASPP)
Replies: 6
Views: 1235

Re: Exodus [32bit version] (2018) (JASPP)

Did you try my previous suggestion? Remove AnyMode and load !ADFFS to enable legacy mode support.
by JonAbbott
Sat Jan 11, 2020 8:36 am
Forum: Games
Topic: Exodus [32bit version] (2018) (JASPP)
Replies: 6
Views: 1235

Re: Exodus [32bit version] (2018) (JASPP)

Thanks for the reply. I did not think ADFFS would be needed, because it's the 32-bit version. So I've not tried with it yet. I'll test that tomorrow. I posted more information in the ROOL thread... May be relevant: When Exodus starts, the ARTEX logo is over to the left side of the screen, and then ...
by JonAbbott
Fri Jan 10, 2020 9:22 pm
Forum: Games
Topic: Exodus [32bit version] (2018) (JASPP)
Replies: 6
Views: 1235

Re: Exodus [32bit version] (2018) (JASPP)

What can I do to help debug this? Probably very little unless you start hacking around with the code to figure out where it's failing. I don't recall which MODE it requires, if your Pi doesn't support the one it wants that could that be the cause? Try running it with ADFFS loaded, or if you already...
by JonAbbott
Sat Jan 04, 2020 3:25 pm
Forum: Pi
Topic: ADFFS 2.73 StrongARM JIT (ARMv4) beta
Replies: 3
Views: 431

Re: ADFFS 2.73 StrongARM JIT (ARMv4) beta

Updated Modules attached to the OP, which fix the full memory sync issue detailed above.
by JonAbbott
Fri Jan 03, 2020 10:38 pm
Forum: Pi
Topic: ADFFS 2.73 StrongARM JIT (ARMv4) beta
Replies: 3
Views: 431

Re: ADFFS 2.73 StrongARM JIT (ARMv4) beta

I've spotted an issue with OS_SynchroniseCodeAreas, which isn't cleaning the JIT cache when a full memory sync is requested. Whilst resolving this issue I also noticed an issue with the ranged clean, which was cleaning a minimum of 128 bytes even if the requested size was smaller. Further testing h...
by JonAbbott
Thu Jan 02, 2020 10:48 pm
Forum: Pi
Topic: ADFFS 2.73 StrongARM JIT (ARMv4) beta
Replies: 3
Views: 431

Re: ADFFS 2.73 StrongARM JIT (ARMv4) beta

I've spotted an issue with OS_SynchroniseCodeAreas, which isn't cleaning the JIT cache when a full memory sync is requested. These are ignored for ARMv3 code as the self-modifying code detection sorts it out, but needs to clean the whole JIT cache when in ARMv4 mode. I purposely ignored it for the A...
by JonAbbott
Tue Dec 31, 2019 9:48 pm
Forum: Pi
Topic: ADFFS 2.73 StrongARM JIT (ARMv4) beta
Replies: 3
Views: 431

ADFFS 2.73 StrongARM JIT (ARMv4) beta

Following this request from Jan Rinze, asking what happened to the StrongARM JIT, I thought I'd get it into a working state and released before the end of 2019! Attached are the updated ADFFS Modules, which should be extracted to the !ADFFS folder, overwriting the originals. To run the JIT in ARMv4 ...
by JonAbbott
Sun Dec 01, 2019 10:33 am
Forum: Games
Topic: Wolfenstein 3D [32bit version] (2018) (JASPP)
Replies: 14
Views: 3814

Re: Wolfenstein 3D [32bit version] (2018) (JASPP)

Nope, sadly I'm stuck on a similar error screen saying Unable to allocate resource table That feels like the most promising error, but however I tweak the min memory options or low memory setting I can't get past that it seems I guess it's hard coded to 2048K min for a reason then. It obviously nee...
by JonAbbott
Tue Nov 26, 2019 8:23 pm
Forum: Games
Topic: Wolfenstein 3D [32bit version] (2018) (JASPP)
Replies: 14
Views: 3814

Re: Wolfenstein 3D [32bit version] (2018) (JASPP)

Having now looked at the source, the only way that error can occur is if its trying to run in MODE 49. Have you gone into the Choices on the Icon Bar app and switched it to MODE 13? You might also want to select the Low memory option. The error itself is misleading, it should be saying "VGA mode isn...