ADFFS 2.56 beta Branch through Zero

Discuss ADFFS development versions and upcoming additions
Post Reply
Trapper
Posts: 12
Joined: Tue May 31, 2016 4:33 pm

ADFFS 2.56 beta Branch through Zero

Post by Trapper » Tue May 31, 2016 4:37 pm

Attached image.

On a StrongARM RISC PC running RISC OS 6.20 with 28MB RAM and 2MB VRAM. No podules, 486 co-processor installed.

Previous release worked fine. Same error occurs on my Raspberry Pi 2 running RISC OS 5.21.

Trapper
Posts: 12
Joined: Tue May 31, 2016 4:33 pm

Re: ADFFS 2.56 beta Branch through Zero

Post by Trapper » Tue May 31, 2016 4:57 pm

Image didn't attach for some reason, Imgur link below:

http://i.imgur.com/vxAsdoe.jpg

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.56 beta Branch through Zero

Post by JonAbbott » Tue May 31, 2016 5:03 pm

Neither machine are supported, as they don't meet the minimum requirements for 2.56 which are detailed in the post you downloaded 2.56 from.

RO5.21 isn't supported, you need to be on the latest RO5.23 beta, it should have reported this when you tried to load ADFFS.

RO6 isn't supported either I'm afraid and 28MB isn't enough RAM, you need 32MB on a RiscPC, I would have expected an error to that affect when trying to boot a game.

When did you get the error? What were you doing at the time it occurred.

Trapper
Posts: 12
Joined: Tue May 31, 2016 4:33 pm

Re: ADFFS 2.56 beta Branch through Zero

Post by Trapper » Tue May 31, 2016 5:21 pm

Wierd as v2.51 worked just fine on RISC OS 6.20.

Error occurred on double clicking !ADFFS to load, previous version I had (v2.51) worked absolutely fine, even with 20MB left after the OS softload

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.56 beta Branch through Zero

Post by JonAbbott » Tue May 31, 2016 5:38 pm

Trapper wrote:Wierd as v2.51 worked just fine on RISC OS 6.20.
There's hundreds of OS version checks, which will all fail with 6. I could recode it to renumber 6.x to 4.x, still no guarantee it will work though, as RO6 isn't a platform we test.
Trapper wrote:Error occurred on double clicking !ADFFS to load, previous version I had (v2.51) worked absolutely fine, even with 20MB left after the OS softload
Go into the !ADFFS folder and try running ADFFS400 on RO6 or ADFFS500 on RO5, then ADFFSFiler to see which is triggering the error.

EDIT: I believe you're hitting this bug on both OS's. Try replacing the files in the attached ZIP and see if it gets it working on RO6.
Attachments
RO6test.zip
(37.56 KiB) Downloaded 17 times

Trapper
Posts: 12
Joined: Tue May 31, 2016 4:33 pm

Re: ADFFS 2.56 beta Branch through Zero

Post by Trapper » Wed Jun 01, 2016 7:20 pm

Just a quick update I haven't had chance to test.

It errors when running RISC OS 4.02 (ROM), but runs fine in RISC OS 4.29 - I'm keeping an eye out for 4.39 ROMs as that seems to be the best RISC PC version.

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.56 beta Branch through Zero

Post by JonAbbott » Wed Jun 01, 2016 8:45 pm

Trapper wrote:It errors when running RISC OS 4.02 (ROM), but runs fine in RISC OS 4.29
It could be a clash with 3rd party software, as it loads on RO4.02 for me. Try the updated files I attached in my previous post on RO6 and let me know if it loads.

If you have a StrongARM, I wouldn't bother attempting to run any games at the minute as I'm still debugging the SA version. The current release will fail with most games.

Post Reply