ADFFS 2.58 beta

Discuss development specific to the Pi version of ADFFS
Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.58 beta

Post by Vanfanel » Wed Sep 07, 2016 4:26 pm

@jon: sorry, but it's not working here. It sometimes enters demo mode briefly then hangs, other times it showns "unimplemented instruction" error, etc...
I have updated ROM, disabled Set ADFFS$50Hz on and off.. nothing seems to work.
My system is running in ARMv7 strict mode, I also tried the other mode.

JonAbbott
Posts: 1739
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.58 beta

Post by JonAbbott » Wed Sep 07, 2016 7:58 pm

Vanfanel wrote:@jon: sorry, but it's not working here. It sometimes enters demo mode briefly then hangs, other times it showns "unimplemented instruction" error, etc...
The Unimplemented instruction was resolved in the latest Modules, did you update the correct Module? ADFFS500 for Pi1, ADFFS550 for Pi2/3.

What's the instruction it's reporting as unimplemented?


Updated Modules and obey.zip on the dev site which get the following working on Pi:

F10286 PowerBand (1990) (The Fourth Dimension) (v1.00) (not on the dev site)
F10619 PowerBand (1990) (The Fourth Dimension) (v2.00)
F10600 PowerBand [SA version] (1998) (The Fourth Dimension)

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.58 beta

Post by Vanfanel » Thu Sep 08, 2016 12:17 pm

@Jon: Powerband works great on Pi2. It's however a bit on the fast side! Cars pass me in the blink of an eye! I believe FPS should be halved or so...

About SWIV, this is what I am getting:

https://www.dropbox.com/s/co7wbk2j61bw3 ... 2.jpg?dl=0

JonAbbott
Posts: 1739
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.58 beta

Post by JonAbbott » Thu Sep 08, 2016 5:45 pm

Vanfanel wrote:About SWIV, this is what I am getting:
What you're looking at there is the beginning of the BASIC Module. How it managed to get there though is another matter, R14 doesn't point at a valid return address so the only thing I can suggest is to do a *MEMORY at the address in R13, to see what's on the stack.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.58 beta

Post by Vanfanel » Thu Sep 08, 2016 7:20 pm

@Jon: How do I do that?

JonAbbott
Posts: 1739
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.58 beta

Post by JonAbbott » Thu Sep 08, 2016 9:08 pm

*MEMORY 14E6C

Although I suspect R13 is corrupt as the dump shows it as 14E6E - which is an invalid stack address.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.58 beta

Post by Vanfanel » Thu Sep 08, 2016 9:13 pm


JonAbbott
Posts: 1739
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.58 beta

Post by JonAbbott » Thu Sep 08, 2016 11:51 pm

As I suspected, it's corrupt and not pointing at the stack.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.58 beta

Post by Vanfanel » Fri Sep 09, 2016 8:49 am

So, what's causing that on my system? I have nothing strange here...

JonAbbott
Posts: 1739
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.58 beta

Post by JonAbbott » Fri Sep 09, 2016 2:30 pm

I have no idea although will hazard a guess at it being timing related. I recall SWIV needed its IRQs to trigger in a certain order and would crash randomly on the title page if that sequence wasn't correct.

Post Reply