ADFFS 2.57 beta

Discuss development specific to the Pi version of ADFFS
JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.57 beta

Post by JonAbbott » Tue Jun 28, 2016 6:00 pm

JonAbbott wrote:
Vanfanel wrote:Diggers is the only "regression" I have seen. It hangs on a black screen after launch.
I've probably broken ModeExtension Modules...if only I could remember another game that uses them, to confirm that theory :?

EDIT: I listed games that use ModeExtension Modules here. They all seem to work, except Diggers.
Hopefully now fixed. Service_ModeExtension was broken although I'm not sure why it wasn't affecting the other games that use it.

Whilst diagnosing this, I also noticed OS_ChangeDymamicArea 2 (eg *ScreenSize) was causing the blitter to crash, which I've also fixed.

EDIT: I've also put the full package on the dev site, I'll release tomorrow or Thursday if neither of us find any further issues.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.57 beta

Post by Vanfanel » Tue Jun 28, 2016 8:32 pm

@Jon: Diggers is workin again, but it has screen refresh problems.
-Frames during the scrolling part of the intro (with the desolated landscape) seems to be repeating, creating an strange effect... hard to describe.
-Cursor is always the clock. It used to change into arrows, etc... before.
-During gameplay, you can see the Diggers are also animated in a strange way, as if frames were repeating very fast.
The same happens with ADDFS$50Hz true or false.

The Last Ninja hangs again as I try to lauch in.
Overload still hangs after the first area. What a game! It's an awesome version of Dropzone!

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.57 beta

Post by JonAbbott » Wed Jun 29, 2016 8:50 am

Vanfanel wrote:@Jon: Diggers is workin again, but it has screen refresh problems.
-Frames during the scrolling part of the intro (with the desolated landscape) seems to be repeating, creating an strange effect... hard to describe.-During gameplay, you can see the Diggers are also animated in a strange way, as if frames were repeating very fast.
The same happens with ADDFS$50Hz true or false.
This only occurs at 50Hz, I'll investigate. It's also randomly crashes if left on the demo loop, which it didn't do previously.
Vanfanel wrote:-Cursor is always the clock. It used to change into arrows, etc... before.
Very odd, none of the recent changes should have affected this, I'll investigate.
Vanfanel wrote:The Last Ninja hangs again as I try to lauch in.
A bug in the boot script, which I've now corrected. It was allocating 40KB instead of the required 160KB of video memory.
Vanfanel wrote:Overload still hangs after the first area. What a game! It's an awesome version of Dropzone!
I've yet to look into this.

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.57 beta

Post by JonAbbott » Wed Jun 29, 2016 10:20 am

JonAbbott wrote:
Vanfanel wrote:@Jon: Diggers is workin again, but it has screen refresh problems.
-Frames during the scrolling part of the intro (with the desolated landscape) seems to be repeating, creating an strange effect... hard to describe.-During gameplay, you can see the Diggers are also animated in a strange way, as if frames were repeating very fast.
The same happens with ADDFS$50Hz true or false.
This only occurs at 50Hz, I'll investigate. It's also randomly crashes if left on the demo loop, which it didn't do previously.
Vanfanel wrote:-Cursor is always the clock. It used to change into arrows, etc... before.
Very odd, none of the recent changes should have affected this, I'll investigate.
The blitter is turning off and the game is writing directly to the GPU memory - hence why you're seeing jittering (the frames are round the wrong way) and also why the pointer stops updating (the Pointer Module writes directly to the legacy mouse pointer location)

Back to the drawing-board on Service_ModeExtension :roll:

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.57 beta

Post by JonAbbott » Wed Jun 29, 2016 4:11 pm

JonAbbott wrote:Back to the drawing-board on Service_ModeExtension :roll:
Try the build I've just put up.

I've rolled back to the previous code (the one that hung on a blank screen), then debugged to find out why it was hanging. For some reason, RISCOS is passing a completely invalid physical address for the screen - it's below the start of the I/O memory mapped for the screen buffer.

Having spend all day trying to figure out why RISCOS is passing an invalid address and getting nowhere, I've given up and changed GraphicsV_SetDAG so it completely ignores the address its passed and instead gets the current display address via OS_ReadVduVariables. I've not tested to see if this works when GraphicsV_SetDAG is called in IRQ mode and have only tested Diggers to confirm it's now correct.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.57 beta

Post by Vanfanel » Thu Jun 30, 2016 9:28 am

@Jon: Diggers works right now, and other games seem to work right, too.
I've tested a bunch of them (Lemmings, Cannon Fodder, Pacmania, Xenon 2, Elite, Wolfenstein...) and they all look right. I will test more tonight.

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.57 beta

Post by JonAbbott » Thu Jun 30, 2016 10:53 am

Vanfanel wrote:@Jon: Diggers works right now, and other games seem to work right, too.
I've tested a bunch of them (Lemmings, Cannon Fodder, Pacmania, Xenon 2, Elite, Wolfenstein...) and they all look right. I will test more tonight.
:D

I'll get it ready for release, I've been testing today whilst recording YouTube videos and all seems good so far - apart from Wonderland and Mig-29 which randomly crash, but suspect they're both Page Zero access errors so am ignoring them for the time being.

To get Burn 'Out working, I had to update RISCOS to a recent build (I'm using 28-06-16) as it was randomly crashing on earlier builds - I suspect it's DSymphonyPlayer at fault here. One of the changes I requested to RISCOS (implemented on 8th June) was for Sound0HAL to preserve the IRQ state around the calls to Channel Handlers, as it was randomly crashing with Page Zero accesses issues on return due to IRQ's being enabled by some Channel Handlers. Prior to the HAL version, Sound0 would still work if IRQ's were enabled, but Sound0HAL makes use of R14 whilst in IRQ mode so will see random corruption of R14 if IRQ's are enabled.

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.57 beta

Post by JonAbbott » Thu Jun 30, 2016 8:52 pm

JonAbbott wrote:
Vanfanel wrote:Overload still hangs after the first area. What a game! It's an awesome version of Dropzone!
I've yet to look into this.
Just looked into this, which was lucky as it turned out to be a bug in the OS_Byte 13/14 code - I had the order of two instructions back to front. Fixed Modules on the dev site, along with the full ZIP. Overload is now working :D

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.57 beta

Post by JonAbbott » Thu Jun 30, 2016 11:24 pm

JonAbbott wrote:I've spent most of the day looking at Simon the Sorcerer's issue and not really got very far. I managed to make it worse when I altered it's SWI code to not stack the SWI before executing it - so it may be SWI related. It's far worse on RO3.71 StrongARM, so possibly a hypervised SWI at fault as the majority of SWI's on RO3.71 are untouched (it doesn't require SWI flag preservation.)
This was being caused by an issue in the Boot script, a corrected obey.zip is now on the dev site.

EDIT: Scrub that...there's a Page Zero access bug to fix as well. I'll need to do some more debugging.

EDIT2: Turns out the issue in the Boot script was actually a fix for the Page Zero access bug...the knock on effect being it caused the mouse issue. Both issues should now be fixed. The root cause is a bug in the game code where it looks like they've mixed C and ASM code, but failed to setup the low stack pointer when calling C.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: ADFFS 2.57 beta

Post by Vanfanel » Fri Jul 01, 2016 12:11 pm

@Jon: Today's versions seems to be working great! I have yet to find regressions, but it doesn't look like there are any.
Simon the Sorcerer works at last! :mrgreen:
Also, testing Alone In The Dark and Flashback is tedious because of the codes... Alone goes past the codes withut entering the right one, but exits back to desktop when actual game is going to start.
Any chances to patch this?

EDIT: Simon The Sorcerer hangs with a black screen when entering the tabern. However, I can go outside the village without problems, or enter the shop.

Post Reply