26bit Module support

Discuss development specific to the Pi version of ADFFS
JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: 26bit Module support

Post by JonAbbott » Fri Oct 16, 2015 11:09 am

Gribbly's scolling is jerky on the show Pi's, so must be related to the monitors running at 75Hz. SWIV - I've left soak testing and it appears to be okay after a few hours.

Updated Modules and obey.zip on the dev site. The big change in this build is that the blitter now performs scaling correction on non-square pixel modes. MODE 15 (eg Rockfall title screen) is now doubled in height and MODE 48 (eg Lemmings 2) is doubled in width. I still have some work to do on the MODE 15 side, for the time being it adds a blank raster on every alternative line until I have time to recode the blitter to duplicate the lines correctly.

On the obey.zip side, I've fixed more Page Zero access bugs in a few games, Rockfall being the main one. I think there's still more remaining though, as I'm still seeing it crash randomly under soak test, on both RC14 and the latest 5.23 build.

5.23 Zero Page relocation support is getting better, I am however seeing crashes in the OS which need tracking down.

I've looked into the scrolling issue in James Pond II and believe its caused by it's lack of any form of Vsync. I should be able to resolve by adding an OS_Byte 19 somewhere in it's code - just need to figure out where to add it.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: 26bit Module support

Post by Vanfanel » Fri Oct 16, 2015 1:41 pm

I have gone from RCA to DVI, and SWIV has hanged here in the tittle sequence, in the programmers faces part...
Also, Lotus 2 hangs with "abort on instruction fetch at &E12FFF3C" after the gameplay demo if it's installed to HD.

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: 26bit Module support

Post by JonAbbott » Fri Oct 16, 2015 11:42 pm

Vanfanel wrote:I have gone from RCA to DVI, and SWIV has hanged here in the tittle sequence, in the programmers faces part...
I left it running 7 hours today and it was still working at the end of it.
Vanfanel wrote:Also, Lotus 2 hangs with "abort on instruction fetch at &E12FFF3C" after the gameplay demo if it's installed to HD.
I highlighted this issue a few posts back, when running games from anything other than the floppy, the filesystem's actions aren't hypervised. The end result being cache's etc aren't flushed and an inevitable code failure occurs. I'd guess the game is in a loop of loading code, executing it, loading the next code, executing it etc.

Its on the list of issues to resolve.

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: 26bit Module support

Post by Vanfanel » Sat Oct 17, 2015 4:25 pm

SWIV is hanging here every time I run it.
If we have different results, then it's time for you to upload a new "full package", please :)
Also, I use AnyModes.

Also, Lotus 2 in HDD does not hang with 2.51b.

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: 26bit Module support

Post by JonAbbott » Sat Oct 17, 2015 5:14 pm

ADFFS252o.zip on the dev site ... now with the complete line doubler. I'm running AnyModes as well.

I'll fire up Lotus Turbo Challenge 2 and test it, busy testing all the London Show machines at the minute. I'm two machines down due to hardware issues!
image.jpeg
image.jpeg (108.83 KiB) Viewed 244 times
Half of the RISCOS London Show machines in soak test...sounds like an Arcade here!!

Vanfanel
Posts: 373
Joined: Mon Sep 16, 2013 12:01 am

Re: 26bit Module support

Post by Vanfanel » Sat Oct 17, 2015 7:40 pm

Wow!! What a nice picture!, Jon!!
I LOVE the noise of several 80-90's games running at one...
Just noticed I can tell what every game is in that picture, btw! From left to right:

-Inferno
-SWIV
-Pacmania
-Last Ninja
-James Pond 2
-Zarch

:ugeek:

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: 26bit Module support

Post by JonAbbott » Sun Oct 18, 2015 9:03 pm

Updated Modules on the dev site, mainly changes to get it running on the Pi2 and Iyonix.

Fixed two bugs in the sound system, the Mouse Pointer is now not rescaled by the OS on a MODE change and I've corrected the Pointer position which was slightly out from where it should have been.

Post Reply