ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Discuss the project, or ask a general question
HeathHayle
Posts: 11
Joined: Fri Mar 03, 2017 5:37 pm

ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by HeathHayle » Fri Mar 03, 2017 5:40 pm

hi guys I am trying to get games working on the raspberry pi 2 using ADFFS I am running Riscos version 5.21 using ADFFS version 2.41 every game I have tried a game from the forum I get Internal error undefined instruction at different address depending on the game like on Lemmings its &20343850 if I try and run the game from the filer I get module not 32bit compatible thanks for your help guys

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by JonAbbott » Sat Mar 04, 2017 7:54 am

The first public release to support Pi2 was 2.59, upgrade to the latest release of ADFFS (currently 2.60) and the games should work. You will also have to upgrade RISCOS to 5.23, as ADFFS relies on OS updates to work.

Never run a game directly as a lot of older titles will alter settings in CMOS or unplug Modules, always use the official releases from this site which detail how to run them on the download page. The majority should be run via "Boot floppy", the only exception to this, off the top of my head, is Casino (Minerva) which should be run directly and Alone in the Dark (Krisalis Software), which has to be installed to HD. Again, each download page details what you need to do for the game in question.

HeathHayle
Posts: 11
Joined: Fri Mar 03, 2017 5:37 pm

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by HeathHayle » Sat Mar 04, 2017 10:10 pm

thanks for your help mate!

HeathHayle
Posts: 11
Joined: Fri Mar 03, 2017 5:37 pm

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by HeathHayle » Mon Mar 06, 2017 1:44 am

how do I upgrade to Riscos 5.23?

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by JonAbbott » Mon Mar 06, 2017 11:32 am

HeathHayle wrote:how do I upgrade to Riscos 5.23?
That's a question probably best asked on the ROOL forum, you'll need to:
  1. Take a backup of everything personal on your SD...just in case
  2. Download the Nightly HardDisc4 image and copy the contents over your SD card from within RISCOS
  3. Save your CMOS to the DOS partition via *SAVECMOS $.!Boot.LOADER.CMOS
  4. Update the Pi firmware files (BOOTCODE.BIN, FIXUP.DAT, START.ELF) - make copies of the originals just in case
  5. Replace RISCOS.IMG with the latest Nightly build
  6. Add the following lines to CONFIG.TXT
    ramfsfile=CMOS
    ramfsaddr=0x508000
  7. Reboot and keep your fingers crossed
The last three steps are best done from the root of the SD on a PC, or $.!Boot.LOADER within RISCOS. I wouldn't advice trying this if you're running a Noobs install as its too easy to trash the boot sequence and end up with an unusable SD. If you are running a Noobs install, overwrite the whole SD with the RC14 SD image first.

If you're using legacy software, you'll also need to copy !ZeroPain from the ROM ZIP to $.!Boot.Choices.Boot.PreDesk. Note that Aemulor does not work past RO5.21, so don't update if you depend on it.

HeathHayle
Posts: 11
Joined: Fri Mar 03, 2017 5:37 pm

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by HeathHayle » Mon Mar 06, 2017 2:40 pm

Thanks so much for your help mate I will give that a go!

HeathHayle
Posts: 11
Joined: Fri Mar 03, 2017 5:37 pm

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by HeathHayle » Mon Mar 06, 2017 5:36 pm

That was one of my issues where do I get the rom from I can't see the nighty build for ROM I can only see the beta etc

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by JonAbbott » Mon Mar 06, 2017 6:01 pm

HeathHayle wrote:That was one of my issues where do I get the rom from I can't see the nighty build for ROM I can only see the beta etc
Follow the link I provided, it's the top file in the ROM Releases section.

HeathHayle
Posts: 11
Joined: Fri Mar 03, 2017 5:37 pm

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by HeathHayle » Mon Mar 06, 2017 10:26 pm

I wasnt sure about that rom about installing it etc and I came across this thread https://www.riscosopen.org/forum/forums/11/topics/6298 and installed the high vector rom (update3) should I remove that and redo it with the other rom you posted because I don't want to wreak my pi etc

JonAbbott
Posts: 1736
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: ADFFS 2.41 on the Pi 2 running RiscOS 5.21 help needed please

Post by JonAbbott » Tue Mar 07, 2017 1:20 am

If you're using Pi firmware newer than Aug 2016, you will need a RISCOS build of Jan 29th or newer to match firmware changes. As detailed in the Pi requirements section on the download page, ADFFS requires at minimum a High Vector (ie official beta) build of RISCOS dated Jun 9th 2016 or newer.

Post Reply