Page 1 of 1

Thundermonk (1989) (Minerva)

Posted: Sun May 08, 2016 10:43 am
by JonAbbott
Image Thundermonk (1989) (Minerva)

ID: 10367
Version: Unknown
Developer: Steve Minifie
Genre: Puzzle
RAM: 1024

CPU compatibility: ARM2 ARM250 ARM3 ARM610 ARM700 ARM710 ARM7500 StrongARM ARMv5+
OS compatibility: 3.11 3.5x 3.6x 3.7x 4.x 5.x

Legal info: Distribution rights granted to JASPP by Minerva

Download: Full archive (1.1mb)


Game info
To run the game use "Boot floppy" from the ADFFS Filer.

The Evil Demons have taken control of The Lonesome Monk's childhood home in his absense. The neighbouring peasants, led by local boy Jason, have tried in vain to gain back power. Brave horsemen bring The Lonesome Monk back from Crusade to lead the rebellion against The Evil Demons. When he catches signt of his valley The Lonesome Monk is enraged at the devastation caused by The Evil Demons. This is war!

You can now lead The Lonesome Monk through the labyrinths of the Monastery against The Evil Demons. Collect the hidden treasures en route, and use the Golden Keys to unlock the Doors of Destiny. Keep your eyes peeled for the secret passages. You too could walk through walls!
Image Image

Re: Thundermonk (1989) (Minerva)

Posted: Fri Aug 19, 2016 2:29 am
by nzjavert
Awesome, You have no idea how long i have waited to play this game again. My Original disk was corrupted years ago. I was so annoyed i have kept the disk as a sad reminder of its death. sadly i have since sold my RO2 chipped A3000 so will have to use under emulation. Thankyou, thankyou thankyou!!!

Re: Thundermonk (1989) (Minerva)

Posted: Fri Aug 19, 2016 10:43 am
by nzjavert
hrmm...I have tried so many things...I have managed to get the file to the point where it is a floppy disk file, but every time i try and load it, it fails and asks if the is disc formatted. I downloaded 3 times just to make sure it wasn't a glitch in the download but to no avail. another issue is when I just double click to load it into adffs it crashes and i have to reboot. Anyone else using va5000 classic os? I used sparkplug to extract the files and that was the only one i could get to work. It has been several years since i last used a risc machine and have forgotten more than i remember now. any help would be great.


Re: Thundermonk (1989) (Minerva)

Posted: Fri Aug 19, 2016 12:08 pm
by JonAbbott
ADFFS doesn't work under most emulators, VA5000 being one of them, most simply don't emulate the machines accurately enough. However, there's a thread detailing how to get VA5000 to open a floppy and which emulators to use here. I'd advice switching to Red Squirrel, a page with download links for most emulators can be found here.