Pipe Mania (1989) (Krisalis Software)

Download games the project has approval to release
JonAbbott
Posts: 1737
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Pipe Mania (1989) (Krisalis Software)

Post by JonAbbott » Sat Apr 30, 2016 12:37 pm

Image Pipe Mania (1989) (Krisalis Software)

ID: 10281
Version: Unknown
Developer: LucasFilm Games, David Lawrence
Genre: Puzzle
RAM: 1024

CPU compatibility: ARM2 ARM250 ARM3 ARM610 ARM700 ARM710 ARM7500 StrongARM ARMv5+
OS compatibility: 3.11 3.5x 3.6x 3.7x 4.x 5.x

Legal info: Distribution rights held by JASPP


Download: Full archive (5.3mb)

Image


Game info
To run the game use "Boot floppy" from the ADFFS Filer.


Synopsis
Pipe Mania is a game of great ingenuity, simple in concept and fiendishly challenging to play.

You'll need to act instinctively, but think strategically!

One wrong move, one brief hesitation or mis-placed pipe section, and you'll drown in a sea of slime!
Screenshots
Image Image
Gameplay

KarateEd
Posts: 29
Joined: Sun Feb 15, 2015 4:05 am

Re: Pipe Mania (1989) (Krisalis Software)

Post by KarateEd » Wed Jul 12, 2017 4:05 pm

Hi Jon,

Today seems to be my day for interesting things happening on my A3010.

With this game, after I try to run it with Boot Floppy I get an error. The error is "File 'y ' not found. the y has an accent across the top of it.

Any idea what this is?

Thanks again,

Ed...... :-)

JonAbbott
Posts: 1737
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: Pipe Mania (1989) (Krisalis Software)

Post by JonAbbott » Wed Jul 12, 2017 5:45 pm

KarateEd wrote:Any idea what this is?
Try running !ADFFS.Obey.F1028101, do you get the same error?

Are you using 2.61? And do other games also report the error when booted?

KarateEd
Posts: 29
Joined: Sun Feb 15, 2015 4:05 am

Re: Pipe Mania (1989) (Krisalis Software)

Post by KarateEd » Wed Jul 12, 2017 7:17 pm

Hi Jon,

The version of ADFFS is 2.5 (June 21 2015)

I've seen reference to !ADFFS.Obey.F1028101 but don't know where to find it first and then how to run it. I suppose if I can find it then a double click to run it?

Edit: OK, now I'm starting to understand, that's a file directory under !ADFFS. obey is white and set to &A91. Do you know if that's the correct Set type for it? I think then F1028101 should be under that? Have I got it about right? and..... I'm now using 2.61 which hasn't really helped this program yet.

Thanks,

Ed...... :-)

JonAbbott
Posts: 1737
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: Pipe Mania (1989) (Krisalis Software)

Post by JonAbbott » Thu Jul 13, 2017 12:02 pm

KarateEd wrote:OK, now I'm starting to understand, that's a file directory under !ADFFS. obey is white and set to &A91. Do you know if that's the correct Set type for it? I think then F1028101 should be under that? Have I got it about right?
Just double click on Obey, its a folder. If it doesn't open, you don't have SparkFS loaded, which is a pre-req.

KarateEd
Posts: 29
Joined: Sun Feb 15, 2015 4:05 am

Re: Pipe Mania (1989) (Krisalis Software)

Post by KarateEd » Thu Jul 13, 2017 10:07 pm

Ok, hopefully only one more question.

My Hard Drive is IDEFS::Part1.$

Will I have to change the F1028101 file to reflect that drive? I have tried that with bad results.

F1028101 has this:

ADFS
Set Obey$Dir ADFS::0.$.!PipeMania
DIR <Obey$Dir>

and then the rest follows I think whatever this part of the config file is....

What I'm also wondering is if I need to change anything ADFS to IDEFS and the 0 in the Set command to Part1. To me that makes sense but there could be reasons that I don't understand that it is wrong.

This stuff is helping me learn more about the RISC OS system, that's for sure.

Thanks Jon,

Ed...... :-)

JonAbbott
Posts: 1737
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: Pipe Mania (1989) (Krisalis Software)

Post by JonAbbott » Thu Jul 13, 2017 10:29 pm

KarateEd wrote:Will I have to change the F1028101 file to reflect that drive?
No, do not modify any of the scripts in Obey; just run F1028101 and see if you get the same error.

KarateEd
Posts: 29
Joined: Sun Feb 15, 2015 4:05 am

Re: Pipe Mania (1989) (Krisalis Software)

Post by KarateEd » Thu Jul 13, 2017 10:52 pm

Ok, what I'm getting is this:

Directory
'ADFS::0.$.!PipeMania' not found

!PipeMania is there though it shows as APP on the icon. Is that right?

Ed...... :-)

JonAbbott
Posts: 1737
Joined: Thu Apr 11, 2013 12:13 pm
Location: Essex

Re: Pipe Mania (1989) (Krisalis Software)

Post by JonAbbott » Fri Jul 14, 2017 7:54 am

KarateEd wrote:Ok, what I'm getting is this:

Directory 'ADFS::0.$.!PipeMania' not found
Was the floppy mounted before running the script? If it was, then your initial error and this imply something odd is going on with FileSwitch, do you have any apps or utilities other than !SparkFS and !ADFFS loaded that could be causing issues? I've seen issues similar to this with LongFiles under RISCOS 3.11 for example.

You could try a clean boot (hold SHIFT when powering on, until at the desktop), you might have to comment out a check in the !SparkFS !Run though before it will load. Then load ADFFS, mount the floppy and try booting and/or running F1028101 directly.

KarateEd
Posts: 29
Joined: Sun Feb 15, 2015 4:05 am

Re: Pipe Mania (1989) (Krisalis Software)

Post by KarateEd » Fri Jul 14, 2017 5:24 pm

Hi Jon,

Final Edit on this post Jon. I took the JFD file and re-downloaded it. I then processed it on the A3010 after a clean boot and darned if it didn't work straight away. I am now suspecting one of 2 things..... The first download was not quite perfect but good enough to load most modules...... or I had stuff running in the background on my A3010 that I was unaware of that caused a faulty install of the program. Not sure which but is there any way to know for sure when you install a program? Can a person tell from the desktop apps exactly what is loaded? Just trying to learn this system and it's fun.... yeh, I've had to do some things many times but it's coming, slowly but surely.

Ed...... :-)

From here down is what I was experiencing before starting from scratch..... sometimes a 'reboot' is necessary to cure issues.

Very strange.....

I was able to get the program to run by using shift, load SparkFS, ADFFS, mount the floppy and then run F1028101.

The strange thing is that within the game the first square is a blank square. The game seems to run as advertised otherwise. It now will follow the pipe flow whereas before it would assume the blank spot was the end of the pipes if that makes sense and the game would end.

Other that cosmetics, it would seem this game is working.

Edit: After a few more plays it seems it's 'mostly' working. Sometimes it does what it used to do but most of the time it plays.....strange. It also doesn't show the level number or the distance to go on the screen. That has never shown up.

One More Edit: The icon that should be the start icon seems to control the direction that the oil or water start out in. If it starts out the wrong direction is why the game ends immediately. However having said that, this is the first time that I've been able to run the game at all, it always crashed me before, maybe I was just extremely unlucky..... better buy a lottery ticket with those odds.

And the last thing I've noticed is no high score table so I think there is something fundamental missing.

When running it from the mounted floppy before, I had no other programs running. When I did, sometimes it would be SparkPlug.....

Just thought of something. I didn't run VIDC this time and it still worked on the screen.... interesting.

Could VIDC cause problems with this game? Edit: Just tested with VIDC and works as describes above.

So the only thing that has changed is that it will now run from the F1028101 file but with missing components it seems.

I'm really having fun trying to learn this system. The interface is beautiful. Wish I'd had this when I was younger. At 67 it's tougher to grasp some things on new systems but this sure is a blast. Easily beats the IBM crap I had after leaving Iceland.

Thanks once again Jon,

Ed...... :-)

Post Reply